Pip

pip install -e / setup.py develop on a cube

published on by

This post was part of the now dead Unlish blog.

The current layout of CubicWeb cubes is not setuptools friendly, and does not permit to use the “develop” mode. The CWEP 004, currently under discussion, aims to solve that problem, and once adopted make life easier for the developers.

Meanwhile, some people (like us at Unlish) would like to use the develop mode anyway, so that we can work on a cube without cloning the whole tree of CubicWeb requirements.

Read More...